ContractFilter Mismatch Error – NiceLabel Designer Error

Target Audience: Advanced User, IT Manager
Article #: 13723

Summary

When launching NiceLabel Designer by clicking on a label file, a user received an error message warning box. The error message read, in part, “The message with Action ‘http://services.nicelabel.com/EPM/AuthenticationService/…’ cannot be processed at the receiver, due to a ContractFilter mismatch at the EndpointDispatcher”

This article explains the error and how to resolve it.

Explanation

The error occurred because NiceLabel Designer and NiceLabel Control Center are different versions. In the case that prompted this article, NiceLabel Designer was newer (v10.2) than the NiceLabel LMS Control Center (v10.1) running on the workstation.

You can determine which versions of the software you are running from within each application:

  • In Designer – Click File -> About. The software’s version and build will be listed.
  • In the Control Center – look for the version and build in the lower-right corner of the window.

Solution

If you find that one program is newer than the other, you will need to bring the older program up to the same version as the newer program (Ex: upgrading v10.1 to v10.2).

NiceLabel Cloud:

  1. Select the Dashboard tab
  2. Click on the Download NiceLabel 10 button
  3. Install as directed

NiceLabel LMS:

  1. Contact EBI for the latest version of LMS
  2. Backup your current version of LMS
  3. Perform an upgrade of LMS
  4. Select the Dashboard tab
  5. Click on the Download NiceLabel 10 button

Additional Comments

Issue found with NiceLabel LMS v10.1 and NiceLabel Designer v10.2.

If you need further assistance, please contact us.

Author


Was this article helpful?

Related Articles